ConnectBooster - Delay in Email Delivery – Incident details

All systems operational

Delay in Email Delivery

Resolved
Degraded performance
Started 5 months agoLasted about 1 hour

Affected

Website

Degraded performance from 3:54 PM to 4:48 PM

Updates
  • Resolved
    Resolved

    Reports have confirmed that the portal is now sending requests for emails once queued, and we have not seen any further or continued degradation. This event is now being marked as resolved.

  • Monitoring
    Monitoring

    We have released a fix for the reported delayed email triggers and are continuing to monitor this for additional reports.

  • Identified
    Identified

    We are currently investigating an incident related to email notifications being queued up for delivery through the ConnectBooster platform. We have received reports that emails are either delayed or not sending completely. Our development team is currently investigating this event.