ConnectBooster - Delay in Email Delivery – Incident details

All systems operational

Delay in Email Delivery

Resolved
Degraded performance
Started 6 months agoLasted 2 days

Affected

Website

Degraded performance from 7:41 PM to 3:05 PM

Updates
  • Resolved
    Resolved

    Reports have confirmed that the portal is now sending requests for emails once queued, and we have not seen any further or continued degradation. This event is now being marked as resolved.

  • Monitoring
    Monitoring

    We have released a fix for the reported delayed email triggers and are continuing to monitor this for additional reports. We are confident that with this release the emails will begin to resolve going forward.

  • Identified
    Identified

    Our Development Team has begun to identify the underlying cause of this degradation and have begun to address the situation for further resolution.

  • Investigating
    Investigating

    We are currently investigating an incident related to email notifications being queued up for delivery through the ConnectBooster Platform. We have received some reports that emails are being delayed when scheduled, and our Development Team is currently investigating this event.